import re
regex = re.compile(r"(\`\`\`\{r \')([A-Za-z0-9-\s]+)")
test_str = "```{r '2b - Possible causes for discrepancy'}"
subst = "**\\2**\\n\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)