use strict;
my $str = '```{r \'2b - Possible causes for discrepancy\'}';
my $regex = qr/(\`\`\`\{r \')([A-Za-z0-9-\s]+)/p;
my $subst = '**\\2**\\n\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";