import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\`\\`\\`\\{r \\')([A-Za-z0-9-\\s]+)";
final String string = "```{r '2b - Possible causes for discrepancy'}";
final String subst = "**\\2**\\n\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}