$re = '/(\`\`\`\{r \')([A-Za-z0-9-\s]+)/';
$str = '```{r \'2b - Possible causes for discrepancy\'}';
$subst = "**\2**\n\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;