re = /(\`\`\`\{r \')([A-Za-z0-9-\s]+)/
str = '```{r \'2b - Possible causes for discrepancy\'}'
subst = '**\\2**\\n\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result