// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\`\`\`\{r \')([A-Za-z0-9-\s]+)").unwrap();
let string = "```{r '2b - Possible causes for discrepancy'}";
let substitution = "**\\2**\\n\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}