# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})/$0-/gm;t' <<< "CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II "