const regex = /(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})', 'gm')
const str = `CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II `;
const subst = `$0-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);