import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})";
final String string = "CORRECT:\n"
+ "via duet fanion aerian aici fiilor feeric diam doe coopera \n\n"
+ "INCORRECT\n"
+ "pii piii \n"
+ "EXPECTED: PII PI-II ";
final String subst = "$0-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}