#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})"
Local $sString = "CORRECT:" & @CRLF & _
"via duet fanion aerian aici fiilor feeric diam doe coopera " & @CRLF & _
"" & @CRLF & _
"INCORRECT" & @CRLF & _
"pii piii " & @CRLF & _
"EXPECTED: PII PI-II "
Local $sSubst = "$0-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)