import Foundation
let pattern = #"(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)