using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})";
string substitution = @"$0-";
string input = @"CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}