re = /(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})/m
str = 'CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II '
subst = '$0-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result