use strict;
my $str = 'CORRECT:
via duet fanion aerian aici fiilor feeric diam doe coopera
INCORRECT
pii piii
EXPECTED: PII PI-II ';
my $regex = qr/(?:[aeiou])(?=[aeiou][bcdfghjklmnprstvwxyz]{0,})/mp;
my $subst = '$0-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";