# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\/\/.*?)(\/courses\/(?:\d+)\/quizzes\/(?:\d+))\/?(?:take)?/\1\/api\/v1\2/gm;t' <<< "https://k12.instructure.com/courses/651977/quizzes/1116753/take"