const regex = new RegExp('(https?://.*?)(/courses/(?:\\d+)/quizzes/(?:\\d+))/?(?:take)?', 'gm')
const str = `https://k12.instructure.com/courses/651977/quizzes/1116753/take`;
const subst = `\1/api/v1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);