import re
regex = re.compile(r"(https?://.*?)(/courses/(?:\d+)/quizzes/(?:\d+))/?(?:take)?", flags=re.MULTILINE)
test_str = "https://k12.instructure.com/courses/651977/quizzes/1116753/take"
subst = "\\1/api/v1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)