using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?://.*?)(/courses/(?:\d+)/quizzes/(?:\d+))/?(?:take)?";
string substitution = @"\1/api/v1\2";
string input = @"https://k12.instructure.com/courses/651977/quizzes/1116753/take";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}