package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?://.*?)(/courses/(?:\d+)/quizzes/(?:\d+))/?(?:take)?`)
var str = `https://k12.instructure.com/courses/651977/quizzes/1116753/take`
var substitution = "\1/api/v1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}