using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img )(src=""[^""]*\/)(.+?)(\..+?\>)";
string input = @"<img src=""../arbitrary/file/path/file-name.jpg"" alt=""arbitrary alt tag""></img>
<img src=""../arbitrary/file/path/file-name.jpg"" alt=""arbitrary alt tag"" /><img></img>
<img src=""../arbitrary/file/path/file-name.jpg"" alt=""arbitrary alt tag f/1.6"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}