$re = '/(<img )(src="[^"]*\/)(.+?)(\..+?\>)/m';
$str = '<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag"></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag" /><img></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag f/1.6" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);