package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<img )(src="[^"]*\/)(.+?)(\..+?\>)`)
var str = `<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag"></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag" /><img></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag f/1.6" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}