import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img )(src=\"[^\"]*\\/)(.+?)(\\..+?\\>)";
final String string = "<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag\"></img>\n\n"
+ "<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag\" /><img></img>\n\n"
+ "<img src=\"../arbitrary/file/path/file-name.jpg\" alt=\"arbitrary alt tag f/1.6\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}