re = /(<img )(src="[^"]*\/)(.+?)(\..+?\>)/m
str = '<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag"></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag" /><img></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag f/1.6" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end