const regex = /(<img )(src="[^"]*\/)(.+?)(\..+?\>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img )(src="[^"]*\\\/)(.+?)(\\..+?\\>)', 'gm')
const str = `<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag"></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag" /><img></img>
<img src="../arbitrary/file/path/file-name.jpg" alt="arbitrary alt tag f/1.6" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}