package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})`)
var str = `29.08.11
19.08.2011
1.1.12
01.1.12
1.01.12
1.1.2021
01.1.2012
1.01.2012
1:1:1
01:1:1
1:01:1
1:1:01
01:01:01
1:12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}