use strict;
my $str = '29.08.11
19.08.2011
1.1.12
01.1.12
1.01.12
1.1.2021
01.1.2012
1.01.2012
1:1:1
01:1:1
1:01:1
1:1:01
01:01:01
1:12';
my $regex = qr/(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}