$re = '/(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})/m';
$str = '29.08.11
19.08.2011
1.1.12
01.1.12
1.01.12
1.1.2021
01.1.2012
1.01.2012
1:1:1
01:1:1
1:01:1
1:1:01
01:01:01
1:12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);