import re
regex = re.compile(r"(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})", flags=re.MULTILINE)
test_str = ("29.08.11\n"
"19.08.2011\n\n"
"1.1.12\n"
"01.1.12\n"
"1.01.12\n"
"1.1.2021\n"
"01.1.2012\n"
"1.01.2012\n\n"
"1:1:1\n"
"01:1:1\n"
"1:01:1\n"
"1:1:01\n"
"01:01:01\n"
"1:12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")