import Foundation
let pattern = #"(\d{1,2}\.\d{1,2}\.\d{2,4})|(\d{1,2}\:\d{1,2}\:\d{1,2})|(\d{1,2}\:\d{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
29.08.11
19.08.2011
1.1.12
01.1.12
1.01.12
1.1.2021
01.1.2012
1.01.2012
1:1:1
01:1:1
1:01:1
1:1:01
01:01:01
1:12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)