import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2}\\.\\d{1,2}\\.\\d{2,4})|(\\d{1,2}\\:\\d{1,2}\\:\\d{1,2})|(\\d{1,2}\\:\\d{1,2})";
final String string = "29.08.11\n"
+ "19.08.2011\n\n"
+ "1.1.12\n"
+ "01.1.12\n"
+ "1.01.12\n"
+ "1.1.2021\n"
+ "01.1.2012\n"
+ "1.01.2012\n\n"
+ "1:1:1\n"
+ "01:1:1\n"
+ "1:01:1\n"
+ "1:1:01\n"
+ "01:01:01\n"
+ "1:12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}