const regex = /\s{2,}\W+(\d+(?:\.\d+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s{2,}\\W+(\\d+(?:\\.\\d+)?)', 'g')
const str = `CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x \$50
CHOC. BANANA x \$13.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}