import re
regex = re.compile(r"\s{2,}\W+(\d+(?:\.\d+)?)")
test_str = ("CHOC. ORANGE x £13.30\n"
"TEST x £1000\n"
"THIS IS A TEST x 50\n"
"MILK x $50\n"
"CHOC. BANANA x $13.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")