import Foundation
let pattern = #"\s{2,}\W+(\d+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)