use strict;
my $str = 'CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00';
my $regex = qr/\s{2,}\W+(\d+(?:\.\d+)?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}