// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s{2,}\W+(\d+(?:\.\d+)?)").unwrap();
let string = "CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}