$re = '/\s{2,}\W+(\d+(?:\.\d+)?)/';
$str = 'CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);