re = /\s{2,}\W+(\d+(?:\.\d+)?)/
str = 'CHOC. ORANGE x £13.30
TEST x £1000
THIS IS A TEST x 50
MILK x $50
CHOC. BANANA x $13.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end