#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<section(.*\s)<\/section>"
Local $sString = "<section class="ui grid topbar">une ligne</section>" & @CRLF & _
"<section class="ui grid topbar">" & @CRLF & _
"<div class="ui row">" & @CRLF & _
" " & @CRLF & _
" ... des divs etc" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
"</section>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")