import Foundation
let pattern = #"<section(.*\s)<\/section>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<section class="ui grid topbar">une ligne</section>
<section class="ui grid topbar">
<div class="ui row">
... des divs etc
</div>
</section>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}