re = /<section(.*\s)<\/section>/
str = '<section class="ui grid topbar">une ligne</section>
<section class="ui grid topbar">
<div class="ui row">
... des divs etc
</div>
</section>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end