// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<section(.*\s)<\/section>").unwrap();
let string = "<section class=\"ui grid topbar\">une ligne</section>
<section class=\"ui grid topbar\">
<div class=\"ui row\">
... des divs etc
</div>
</section>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}