# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ -]//g;t' <<< "+65555-555-555 555555
+65555-555 555 555555"