#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[ -]"
Local $sString = "+65555-555-555 555555" & @CRLF & _
"+65555-555 555 555555"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)