use strict;
my $str = '+65555-555-555 555555
+65555-555 555 555555';
my $regex = qr/[ -]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";