using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ -]";
string substitution = @"";
string input = @"+65555-555-555 555555
+65555-555 555 555555";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}