import Foundation
let pattern = #"[ -]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+65555-555-555 555555
+65555-555 555 555555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)