using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?!\.)[\w\/])*?)\/?$";
string substitution = @"$1.cfm";
string input = @"/someScript
/module/employee/anotherScript
/someScript/
/module/employee/anotherScript/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}