const regex = /^((?:(?!\.)[\w\/])*?)\/?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:(?!\\.)[\\w\\\/])*?)\\\/?$', 'gim')
const str = `/someScript
/module/employee/anotherScript
/someScript/
/module/employee/anotherScript/`;
const subst = `$1.cfm`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);