import re
regex = re.compile(r"^((?:(?!\.)[\w\/])*?)\/?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("/someScript\n"
"/module/employee/anotherScript\n"
"/someScript/\n"
"/module/employee/anotherScript/")
subst = "$1.cfm"
result = regex.sub(subst, test_str)
if result:
print(result)